5
0
mirror of git://git.proxmox.com/git/lxc.git synced 2025-03-14 04:58:54 +03:00
lxc/debian/rules
Wolfgang Bumiller a5021a1ac4 d/rules: compat level 10 fixups
And add a patch to add an ExecReload for lxc.service.

Signed-off-by: Wolfgang Bumiller <w.bumiller@proxmox.com>
2019-08-07 10:24:45 +02:00

43 lines
1.1 KiB
Makefile
Executable File

#!/usr/bin/make -f
# output every command that modifies files on the build system.
#DH_VERBOSE = 1
# see EXAMPLES in dpkg-buildflags(1) and read /usr/share/dpkg/*
DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/default.mk
%:
dh $@ --with autoreconf,quilt,systemd
override_dh_auto_configure:
dh_auto_configure -- \
--with-distro=debian \
--with-init-script=systemd \
--enable-apparmor \
--enable-doc \
--enable-api-docs \
--disable-rpath \
--disable-selinux \
--enable-bash \
--disable-cgmanager \
--disable-python \
--disable-lua \
--disable-examples \
--enable-seccomp \
--disable-static \
--with-cgroup-pattern='lxc/%n'
override_dh_fixperms:
dh_fixperms -Xusr/lib/$(DEB_HOST_MULTIARCH)/lxc/lxc-user-nic
override_dh_install:
rm -f debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)/*.la
dh_apparmor -p lxc-pve --profile-name=usr.bin.lxc-start
dh_apparmor -p lxc-pve --profile-name=lxc-containers
dh_install --fail-missing
override_dh_systemd_start:
dh_systemd_start -plxc-pve -r lxc-monitord.service lxc-net.service
dh_systemd_start -plxc-pve -r --no-restart-after-upgrade lxc.service