7200cd7e23
Signed-off-by: Thomas Lamprecht <t.lamprecht@proxmox.com>
97 lines
2.7 KiB
Plaintext
97 lines
2.7 KiB
Plaintext
rust-proxmox-time (2.0.3-1) bookworm; urgency=medium
|
|
|
|
* also implement `From<&TimeSpan> for f64` to support taking a reference, as
|
|
we do not require ownership here.
|
|
|
|
-- Proxmox Support Team <support@proxmox.com> Tue, 26 Nov 2024 16:52:28 +0100
|
|
|
|
rust-proxmox-time (2.0.2-1) bookworm; urgency=medium
|
|
|
|
* time span:
|
|
- drop trailing space when not showing seconds at end
|
|
- avoid displaying months with a minute time unit
|
|
- use single-letter time unit variant for displaying minutes
|
|
- add basic module level docs
|
|
|
|
-- Proxmox Support Team <support@proxmox.com> Thu, 17 Oct 2024 16:13:23 +0200
|
|
|
|
rust-proxmox-time (2.0.1-1) bookworm; urgency=medium
|
|
|
|
* replace lazy_static with std's LazyLock and drop dependency
|
|
|
|
* various typo fixes in the documentation
|
|
|
|
-- Proxmox Support Team <support@proxmox.com> Wed, 14 Aug 2024 11:07:49 +0200
|
|
|
|
rust-proxmox-time (2.0.0-1) bookworm; urgency=medium
|
|
|
|
* fix warnings when building for wasm32
|
|
|
|
* bump bitflags dependency to 2.4
|
|
|
|
-- Proxmox Support Team <support@proxmox.com> Thu, 20 Jun 2024 13:44:56 +0200
|
|
|
|
rust-proxmox-time (1.1.6-1) stable; urgency=medium
|
|
|
|
* add strftime_l bindings
|
|
|
|
* add epoch_to_rfc2822
|
|
|
|
-- Proxmox Support Team <support@proxmox.com> Mon, 08 Jan 2024 12:17:05 +0100
|
|
|
|
rust-proxmox-time (1.1.5-1) stable; urgency=medium
|
|
|
|
* re-add epoch_to_rfc3339_utc on wasm target
|
|
|
|
* rust edition cleanup
|
|
|
|
* clippy fixes
|
|
|
|
-- Proxmox Support Team <support@proxmox.com> Thu, 12 Jan 2023 14:20:10 +0100
|
|
|
|
rust-proxmox-time (1.1.4-1) stable; urgency=medium
|
|
|
|
* Update to nom 7
|
|
|
|
-- Proxmox Support Team <support@proxmox.com> Fri, 19 Aug 2022 12:21:16 +0200
|
|
|
|
rust-proxmox-time (1.1.3-1) stable; urgency=medium
|
|
|
|
* Allow to compile on wasm32 target
|
|
|
|
-- Proxmox Support Team <support@proxmox.com> Fri, 03 Dec 2021 09:23:46 +0100
|
|
|
|
rust-proxmox-time (1.1.2-1) stable; urgency=medium
|
|
|
|
* calendar-events: parse 'UTC' timezone into calendareven
|
|
|
|
-- Proxmox Support Team <support@proxmox.com> Thu, 02 Dec 2021 10:36:15 +0100
|
|
|
|
rust-proxmox-time (1.1.1-1) stable; urgency=medium
|
|
|
|
* time-span: implement FromStr
|
|
|
|
* calendar_events: implement FromStr
|
|
|
|
* calendar-events: make compute_next_event a method
|
|
|
|
* calendar-events: make hour optional
|
|
|
|
* calendar-events: implement repeated ranges
|
|
|
|
-- Proxmox Support Team <support@proxmox.com> Wed, 01 Dec 2021 07:16:36 +0100
|
|
|
|
rust-proxmox-time (1.1.0-1) stable; urgency=medium
|
|
|
|
* proxmox-time: remove custom error type
|
|
|
|
* proxmox-time: added time related fuctions from proxmox-systemd crate
|
|
|
|
-- Proxmox Support Team <support@proxmox.com> Wed, 17 Nov 2021 11:36:15 +0100
|
|
|
|
rust-proxmox-time (1.0.0-1) stable; urgency=medium
|
|
|
|
* initial split out of `librust-proxmox-dev`
|
|
|
|
-- Proxmox Support Team <support@proxmox.com> Mon, 04 Oct 2021 11:38:53 +0200
|