infra/shell.nix
2018-10-25 12:13:36 +04:00

24 lines
463 B
Nix

{ pkgs ? import <nixpkgs> {}
, windowsSupport ? false
}:
with pkgs;
let
pytest-bdd = callPackage nix/pytest-bdd {};
proxmoxer = callPackage nix/proxmoxer {};
ansible = callPackage nix/ansible {};
myPython = python27.withPackages (ps: with ps; [ pytest-bdd proxmoxer jmespath virtualenv pip hypothesis pytest_xdist pytest ]);
in
stdenv.mkDerivation {
name = "alt-infra-ansible";
buildInputs = [
openssh
ansible
myPython
pass
];
}