cd8984a954
Signed-off-by: Wolfgang Bumiller <w.bumiller@proxmox.com>
26 lines
784 B
Makefile
Executable File
26 lines
784 B
Makefile
Executable File
#!/usr/bin/make -f
|
|
|
|
include /usr/share/dpkg/pkg-info.mk
|
|
include /usr/share/rustc/architecture.mk
|
|
|
|
#export DH_VERBOSE=1
|
|
export BUILD_MODE=release
|
|
|
|
CARGO=/usr/share/cargo/bin/cargo
|
|
|
|
export CFLAGS CXXFLAGS CPPFLAGS LDFLAGS
|
|
export DEB_HOST_RUST_TYPE DEB_HOST_GNU_TYPE
|
|
export CARGO_HOME = $(CURDIR)/debian/cargo_home
|
|
|
|
export DEB_CARGO_CRATE=pve-rs_$(DEB_VERSION_UPSTREAM)
|
|
export DEB_CARGO_PACKAGE=pve-rs
|
|
|
|
%:
|
|
dh $@
|
|
|
|
override_dh_auto_configure:
|
|
@perl -ne 'if (/^version\s*=\s*"(\d+(?:\.\d+)+)"/) { my $$v_cargo = $$1; my $$v_deb = "$(DEB_VERSION_UPSTREAM)"; \
|
|
die "ERROR: d/changelog <-> Cargo.toml version mismatch: $$v_cargo != $$v_deb\n" if $$v_cargo ne $$v_deb; exit(0); }' Cargo.toml
|
|
$(CARGO) prepare-debian $(CURDIR)/debian/cargo_registry --link-from-system
|
|
dh_auto_configure
|